Auswertungen

Der Spaltendialog beinhaltet auch Funktionalitäten, um verschiedene Auswertungen durchführen zu können. Die vorgestellte Datenbank Buchversand soll sich auch zum Erstellen von Rechnungen nutzen lassen. Dies bedingt Erweiterungen am Datenmodell und Ergänzungen für einige Tabellen.

Zunächst einmal erfordert dies eine Tabelle mit Informationen zu Kunden. Dazu lässt sich die Tabelle Autoren heranziehen, sie enthält sämtliche Angaben (Adresse, Kommunikationsdaten, etc.) zu Personen. Ändern Sie deshalb ihren Namen um in Personen. Der Inhalt eines zusätzlichen Felds vom Typ Mehrfachauswahl soll kennzeichnen, ob es sich bei einer Person um einen Autor, Kunden oder einen anderen Kontakt handelt.

Kopie_von_Handbuch_komplett_html_49d45463

Die Kennzeichnung von Kontakttypen in Tabelle »Personen«.

Zur Erfassung von Rechnungsinformationen sind zwei weitere Tabellen Rechnungen und Rechnungspositionen notwendig, und Tabelle Bücher muss ein weiteres Feld für Preisangaben enthalten. Die Komplexität des Datenmodells hat dadurch deutlich zugenommen.

Kopie_von_Handbuch_komplett_html_31c12115

Das Datenmodell mit Tabellen für Rechnungsinformationen.

Für die beiden neuen Tabellen sind die in der folgenden Abbildung aufgeführten Felder und Verknüpfungen definiert.

Kopie_von_Handbuch_komplett_html_252907ed

Kopie_von_Handbuch_komplett_html_5369923f

Die Felder und Verknüpfungen von »Rechnungen« (links) und »Rechnungspositionen« (rechts).

Als Folge der neu eingerichteten Verknüpfungen taucht jetzt im Formular Rechnungen die Tabelle

Rechnungspositionen als Tabellendarstellung auf.

Kopie_von_Handbuch_komplett_html_a8cfa7b1

Die Tabelle »Rechnungspositionen« in Tabellendarstellung im Formular »Rechnungen«.

Diese Darstellung ähnelt nicht nur vom Erscheinungsbild her einer Ansicht, sie lässt sich analog konfigurieren. Die Spaltendialoge beispielsweise unterscheiden sich nicht.

Kopie_von_Handbuch_komplett_html_84168f39

Der Spaltendialog für Tabelle »Rechnungspositionen«.

Und auch die Auswahl der einzublendenden Spalten funktioniert analog.

Kopie_von_Handbuch_komplett_html_1bfbe34d

Kopie_von_Handbuch_komplett_html_8f1397af

Die Auswahl einzublendender Spalten für Tabelle »Rechnungspositionen«.

Nach Fertigstellung dieser Konfigurationsmaßnahmen sowie der Auswahl von Büchern für eine Rechnung hat die Tabelle Rechnungspositionen Formular Rechnungen die in der folgenden Abbildung dargestellte Gestalt angenommen.

Kopie_von_Handbuch_komplett_html_bb83f8ff

Die Tabelle »Rechnungspositionen«nach erfolgter Konfiguration.

Zur Ermittlung des Gesamtbetrags einer Rechnung müssen Sie nun einfach für Verkaufspreis im Spaltendialog die Statistikfunktion Summe per Mausklick auswählen.

Kopie_von_Handbuch_komplett_html_1c011a2e

Auswahl einer Funktion im Spaltendialog.

Diese Maßnahme ergänzt die Tabelle um eine Auswertungszeile. In diesem Fall erscheint der Gesamtpreis der Rechnung unterhalb der letzten Position.

Kopie_von_Handbuch_komplett_html_9cf52173

Eine Tabelle mit einer Auswertungszeile.

Der Gesamtpreis einer Rechnung soll nun auch als Spalte in einer Ansicht von Rechnungen erscheinen. Dazu müssen Sie wieder den Spaltendialog bemühen.Die benötigte Statistikfunktion Summe können Sie im im letzten Einblendmenü dieses Vorgangs auswählen.

Kopie_von_Handbuch_komplett_html_1251c502

Kopie_von_Handbuch_komplett_html_6f3a81e6

Kopie_von_Handbuch_komplett_html_12cc49e1

 

In der Ansicht (alle) von Rechnungen erscheint nun der aus den Einzelpositionen ermittelte Gesamtpreis.

Kopie_von_Handbuch_komplett_html_f46d6c0f

 

Für Ansichten können Sie sich ebenfalls die Anzeige von Ergebisse statistischer Funktionen in einer Auswertungszeile darstellen lassen. Standardmäßig ist dies für die Spalte Nr aktiviert. Hier zeigt Ninox die Anzahl der aktuell dargestellten Datensätze an. in der folgenden Abbildung ist dies um die Gesamtsumme der Rechnungen sowie das Datum der zuletzt erstellten Rechnung angezeigt. Für letzteres müssen Sie die Funktion Maximum auswählen.

Kopie_von_Handbuch_komplett_html_ce8a53dc

Die Ansicht »(Alle)« von »Rechnungen« mit statischen Auswertungen.

Um eine solche Auswertung wieder zu löschen, müssen Sie im Spaltendialog einfach auf die aktuell blau hinterlegte Statistikfunktion klicken.

Kopie_von_Handbuch_komplett_html_eebf7318

 

Die Ergebnisse von Auswertungszeilen beziehen sich immer auf die jeweils aktuelle Ergebnismenge. Diese können Sie mit Hilfe der Such- oder Filterfunktionen einschränken. In diesen Fällen ist die Auswertungszeile gelb hinterlegt.

Kopie_von_Handbuch_komplett_html_7bae9be2

 

Solche Ergebnismengen lassen sich auch durch das Markieren von Datensätzen erzeugen. Dazu müssen Sie einfach auf den Kopf der auserkoren Zeile klicken. Solche Datensätze sind dann mit einem Häkchen gekennzeichnet. Ein weiterer Mausklick hebt eine Markierung wiederauf.

Kopie_von_Handbuch_komplett_html_b4354d

Die Erzeugung von Ergebnismengen mittels Markierung von Datensätzen.