function duration*value/3600000 returns different results in form or table view


Why result of same function duration*value/3600000 appears correct in table form view and return result "0m" in table view?


Ninox Profile


Please check the number format of the formula field, the number of decimal places or unit of the number field that might effecting the result. If you could share a screeshot of the result, we should be able to provide a solution to you. 

Thank you,

Ninox Support


Screen Shot 2019-04-15 at 6.00.59 PM

Screen Shot 2019-04-15 at 6.00.43 PM


Ninox Profile

Same here. Was this solved?


Hi Christian. I'm not sure if this was exactly solved the way I phrased it/was looking at it at the time.
What I can offer is an amateurish explanation of why that isn’t a problem for me anymore… What I didn’t realize at the time is everything is measured in milliseconds. 1 minute is 6000 milliseconds, 1 hour is 3,600,000 milliseconds and so on.

Now when I am trying to find the passage of time now I have the field number format set to 0.00 and do a simple number(timeOut – timeIn)/3,600,000. This gives me number value I am looking for.

One thing I have noticed with subTables in Ninox- sometimes when I update a record in a subTable, close and am viewing the subtTable columns from the masterTable, the values in the columns sometimes don’t update immediately. Several minutes, closing database out, resyncing, and hiding then showing column again are work-around solutions to this problem that I’ve found. This matters, because if this is a subtable you could potentially make all the correct changes but they may not be immediately reflected in the master table.

Hope this helps. Again, I’m no expert, just someone that uses Ninox and is trying to learn!