http() function isn't working

Ninox Profile

Sent 3rd email request for information regarding this issue today. Have not received a reply for either of my previous 2 requests for information.

Ninox Profile

Update: I just finished a Zoom meeting with Sam at Ninox and was told this functionality that I developed my app around was never intended to be available in the Mac app. So, my take away is that the functionality exists, but has been removed from the Mac app and is now only available in the browser version. You can draw your own conclusions about that... €. I was told that other users have complained about this loss of functionality, but it remains to be seen if it will be returned. 

Ninox Profile

I want to add that running my code through the browser version is incredibly slow. I haven't tried wrapping all of my user defined functions in do as server, but at this point I think I have pretty much lost interest in working with a product where functionality is disabled without notifying developers first.

Ninox Profile

Update: I received an email Friday a couple of hours after my Zoom meeting with support...

 

-----

Hi Sean,

thank you for the meeting today.
I need to apologize, I think I misunderstood something. Let me clarify the issue and what we will do.
It is right, that it was possible and is supposed to be possible to make http requests and receive the response from the Mac App.
It is not possible to make another service send a request to a local or iCloud database, but I think you knew this already and used it the correct way all the time.

Since one of our last updates we integrated a new internal feature which also included an upgrade to the latest security standards.
Because of this, some API calls don't work because the origin (in that case the origin of the local database) is unknown to the service receiving the request.
For some reason this also happens when a local database is sending a request to ninox.com.
As for ninox.com, it is an issue we can fix. I forwarded this to our developers already.
But we can't influence other websites and servers.

We hope that we can release the fix in the near future.
Thanks for your patience.

-----

 

Hopefully, this will be resolved soon. I also want to point out that making an http call to a local file saved in a Ninox database isn't working either. It used to work and can be useful when you want to extract all or part of a text file.

Ninox Profile

Not fixed in Version 3.3.4 

M

Hi Sean

Thats very worrying when a seasoned and well respected user like you gets disallusioned.

Ninox is great but it has some incredably basic flaws that is extremely irritating!

I too had a Zoom meeting on tuesday - basically the backup files when reaching a certain size (cloud version) seem no longer restore! - very worrying! 

Whilst on this session, I asked why has all Ninox staff prescence stopped on the forum during the last year.! I was told that they don't have time to spare to participate on the forum!. However they do intend to employ someone who will monitor/liaise with the forum hopefully in the near future!. Hmm - you can only ignore your paying customers for so long!

Sean - Please hang in there my friend - People like me really value your contibutions and you have provided such great insight into the dark art of scripting etc and so much more than you may realise.  Since i moved to Ninox some 15 months ago you have certainly helped me on many occasions for with I am forever thankful - :-)

Kind regards

Mel

Ninox Profile

In my experience, when i use 'do as server' in my http request it works. If I don't, it blocks. e.g.:

let responce := do as server

http("GET",".........

end

Steven

Ninox Profile

Sean, I agree with Mel's points 100% -- especially on how much your contributions are valued! You have always responded to my SOS (questions) ... for which I am SO appreciative! Other people have as well (and again, I'm grateful to all! ) and I would hate for this forum to be degraded in any way!

And as my skills have improved I try to 'pay it forward' by answering any questions I possibly can (which so far, aren't as many as I'd wish to ... but I'm working on it! :-)

Karen

Ninox Profile

Hi Mel,

Thank you again for your kind words. I'm afraid I'm not in the category of users they are trying to lure - No-Co, Lo-Co's.

 

As long as I'm still learning and not hitting too many walls, I'll continue to work with Ninox. I agree that there are some fundamental features that are missing like changing app colors or choosing different fonts. That is easy stuff and the kind of shiny baubles that I would think No-Co, Lo-Co users would be attracted to.

 

Ninox are very fortunate that they have an enthusiastic user base. Birger has 3 forum accounts and hasn't used his official one in over a year. I don't know if he even works there anymore, but he seemed to be the most knowledgeable of the tech support personnel. Unless the context is unreleased functionality, I think the user base knows more about how to use the product than any current tech support agent they have. Support, feel free to speak up.

 

Best regards,

Sean

Ninox Profile

Hi Steven,

I tried that and it still doesn't work. As you can see from the contents of the email from support, they acknowledge the functionality was disabled in the Mac app. I have tried wrapping all my UDFs in do as server in the browser version and it is simply unusable. It would take just a couple of seconds in the Mac app to scrape a single forum thread, but it takes an indeterminable amount of time in the browser version because I am unwilling to watch the spinning wheel of doom for very long and I Force Quit the browser session.

 

In this thread https://ninox.com/en/forum/ideas-and-suggestions-5abb9f4f45eda7ea1e75ed02/field-grouping-layout-element-5cd9e19a30c4436c2e2e0fda?post=5f4c62a28dfe7919e5b3904a&page=1 I point out to Dean that I scraped 1000 threads, some of those have more than one page to scrape, in about 25 minutes. I could probably only scrape 5 in the browser version if it worked at all.

 

Regards,

Sean

Reply