!!! SOS - Ninox Crash on iPadPro 12.9 2017 since update 2.5.3

Ninox Profile

Hi all,


Ninox totally crashes on my iPadPro 12.9 (Model 2017) immediately after starting the App since last update 2.5.3 (todays update 26.03.2019). On iPhone all is fine.

Restart App and reboot does not help!!


iPadPro 12.9 Modell 2017

iOS 12.1.4

Standalone usage without server but using iCloud-Sync between devices.


As I use a bunch of self written Ninox-Apps on a daily basis, I much would appreciate any help and/or fixes!

Please no such advices like "delete the app and reinstall"!




Ninox Profile

Please check if it runs

a) without Internet

b) connected to WLAN

We'll publish a fix for this today, available probably tomorrow in the morning.

Ninox Profile

Thanks a lot for the qick answer/advice!!

In Flight-Mode it works. WLAN I'll check later on and give you feedback!



I can confirm that the iPad runs with internet turned off (but can't get iCloud databases!). No WiFi nearby, so I used my iPhone as a hotspot, connected the iPad, and all worked well. Turned off the hotspot, and the iPad continues to work.

Next, I did the reverse by making the iPad a hotspot and connecting the iPhone. Ninox did not crash, even after turning off the hotspot.


Ninox Profile

In the meanwhile I tried using WiFi as internet connection and all is working fine. Switching WiFi off and only using celular network without(!) terminating ninox before, the ninox app continues running without problems.

If Interminate the ninox app  a complete App and try to restart only in celular mode, ninox always crashes.

So I suppose that some initializing code while having only a celular internet connection in conjunction with icloud enabled databases makes the app crashing.

Best Christoph

Ninox Profile

Autocorrection: It must be "... If I terminate the ninox app (remove it from memory by closing) and try to restart only in celular mode, ..."


I have the same problems with iPhone app as well. Black screen once connected through Cellular data. It can be opened without internet connection, however no iCloud database is visible.

Ninox Profile

Updates for iPad and iPhone are now available on the App Store.

I apologize for the inconvenience. 


Ninox Profile

It is December 20, 2019 and I am having this problem now.  If my iphone 8+ is using data, the app does not load.  It is just a black screen.  It will work offline and on wifi.  I have tried opening things in Airplane mode and then turning Airplane mode off once that app is open, but it freezes after a couple taps.  Is there any sort of fix?


Ninox Profile

Ok so I think I figured this out for my situation.  I don't know why there are so many different options for cellular data, but not only do you have to allow Ninox to use cellular data you also have to make sure iCloud has permission to use cellular (I didn't know this option existed).  Under Settings -> Cellular at the very bottom there is the option called "iCloud Drive".  It gives you the option to use cellular network to transfer documents and data when not on wifi.  I figured that the toggle switch for Ninox would include documents and data, but it doesn't.  Once I toggled that on, everything worked great on cellular.  

1 2